enfr

Snapshots and variance

Updated: 2017-03-14

Snapshots allow you to record a point-in-time for the data in a tax return. Then, you can use this information to make comparisons when planning or to prepare adjustments to the return.

Take a snapshot

  1. Go to the Tools menu and click Take Snapshot (or, press Ctrl+F10).
  2. (Optional) Enter a Description for the snapshot.
  3. Choose which type of snapshot to save (see below).
  4. (Optional) Check Show variance to immediately enable the comparison between the new snapshot and any subsequent changes.
  5. (Optional) Add Notes to record more details about the snapshot.
  6. Click Create to save the snapshot.
  7. A status event is added to the file History each time you create a snapshot.

2019-take-snapshot636850668987267174

Types of snapshots

TaxCycle creates two types of snapshots. It's important to understand the difference so you can create the type that works best for what you want to do.

Comparative (automatic or manual)

Captures all the fields in the tax return. Use this snapshot for planning or comparing tax scenarios as you make changes to the file.

As filed (automatic or manual)

Captures only the fields that are needed when filing the return. TaxCycle automatically creates this type of snapshot when you transmit a return using T1 EFILE, ReFILE or T2 Corporation Internet Filing.

Automatic snapshot creation


  • TaxCycle automatically creates an As filed snapshot when you successfully transmit a return or print the T1Condensed for filing on paper in TaxCycle T1.
  • When you open an existing return in which the Electronic filing or Completed task is already checked, TaxCycle looks for an As filed snapshot. If there isn't one, it prompts you to create one.  
  • A snapshot is taken automatically when you carry forward a return from the prior year. This snapshot contains the data from the prior-year for comparison with the data for the current year.
  • You can also configure printer and output options to automatically take a snapshot when printing a print set or a form. Choose a snapshot type from the Take snapshot menu in printer and output option. To learn more about printer and output options, read the Printer and PDF output options.
2019-take-snapshot-upon-printing

Show/hide variance

You can use snapshots for comparison. This is useful for planning or to determine the best result for your clients.

  1. Click Show Variance in the Tools menu.
  2. Select a snapshot to use as sa comparison. The selected snapshot shows a check mark next to it.
  3. TaxCycle identifies fields and forms that contain values different from the snapshot. Fields with variance from the snapshot have an orange corner and/or an orange background).
  4. Hover over a field to see the amount recorded in the snapshot.
  5. Forms with variance have a different form icon so they are easy to find.
  6. Select Variance from the views list in the Prepare sidebar to see a list of forms with variance from the snapshot.
  7. Select Variance from the views list in the Review sidebar to see a list of review messages highlighting fields that vary from the snapshot.
  8. To hide variance review messages and end the comparison, select No Variance.

2019-show-variance

Set thresholds and fields that trigger variance

Adjust the thresholds for triggering variance and the types of fields that can have variance:

  1. Variance optionsTo open Options from the Start screen, click Options in the blue bar on the left side. If you have a file open, go to the File menu, then click Options.
  2. On the left side of the dialog box, expand the T1/TP1 (or any other module) section, then click on Variance to set the same options for all years. Or, expand Variance and click on a year to set different options for each year.
  3. Set minimum dollar amount or percent that triggers variance messages.
  4. Check the boxes to include unused forms, text fields, and/or fields without line numbers.
  5. Variance is detected on All fields by default, but you can choose to restrict it to Edit fields or Calculated fields instead.

Delete snapshots

  1. All snapshots appear in the order taken under Show Variance on the Tools menu.
  2. You can delete a snapshot by clicking the delete button to the right of the snapshot's name.

2019-delete-snapshot