Menu

Import GIFI from a File

Updated: 2020-10-22

TaxCycle T2 and TaxCycle T5013 can import the amount in General Index of Financial Information (GIFI) format from a file with a GFI, CSV or TXT extension.

This includes files exported from:

Import a GIFI File

To import GIFI into a return, open a T2 or T5013 return, then drag and drop the GIFI file onto the TaxCycle window. Or:

  1. Go to the Data menu.
  2. Click on Import GIFI and select Import GIFI.
  3. Browse for the file you want to import.
  4. Click Open.

TaxCycle imports the GIFI codes and related balances to the correct lines on the GIFI schedules (S100, S101, and S125) and into the Info worksheet (if that information is included in the file, but we'll never overwrite the company name and business number you've carried forward). If there are notes to the financial statements included in the GIFI export, these are inserted onto the Notes page in TaxCycle.

Icon: Imported Data on Form
Icon: Imported Data
Forms that contain imported values have an orange asterisk on the form icon.

You can update the GIFI values in the tax return at any time by reimporting a GIFI file using the same steps as above. TaxCycle will remember where you last imported a GIFI from, so it is easy to find the file again.

Sample GIFI file

If you'd like to try importing into TaxCycle, we've included a sample file in with TaxCycle so you try it out.

C:/Program Files (x86)/Trilogy Software/TaxCycle/Samples/Sample QuickBooks® GIFI Export.csv

You can also use this file to create your own spreadsheet for GIFI import. Just copy the format provided.

Replace GIFI Notes on Import

You can set whether GIFI notes get re-imported in options:

  1. On the File menu, click on Options.
  2. On the left, expand T2 (or T5013) and click on General to apply the settings to all years. To set different options for a particular year, expand the section and click on a year.
  3. Under the GIFI section on the right, check Replace T2 notes when GIFI notes are re-imported.

Screen Captures: Replace T2 notes when GIFI notes are re-imported

Default GIFI Import File Path

You can set a default import path for GIFI files. If you are importing GIFI for the first time for a file, TaxCycle opens the default folder as specified in options. However, if you are importing GIFI for a second or subsequent time, TaxCycle will remember the last GIFI import folder and will open that folder.

To set this default:

  1. On the File menu, click on Options.
  2. On the left side of the dialog box, expand Files and folders, then click on Common Folders.
  3. Scroll down to the GIFI section.
  4. To automatically sync the default GIF folder with that used for T2 client files, check the first box.
  5. To set a separate folder, click on the browse button to select a folder.
  6. Click OK to save your changes.

Screen Capture: GIFI File Path

Haven't found the answer? We can help.

Contact us and we’ll get back to you as soon as possible.